Don't make two or more things at once.
TL;DR: Try to be as atomic as possible in your methods
Harder to test
Harder to read
- Break the method
If you name a method with 'And' you are probably missing an extract-and-break method opportunity.
calculatePrimeFactorsRemoveDuplicatesAndPrintThem() // Three responsibilities
calculatePrimeFactors(); removeDuplicates(); printNumbers(); // Three diferent methods // We can test them and reuse them
Some linters can warn us about methods including the term 'and'.
When making methods, it is very important to play some rubber duck story and tell ourselves if we are making things right.
Code Smells are just my opinion.
Learning the art of programming, like most other disciplines, consists of first learning the rules and then learning when to break them.
This article is part of the CodeSmell Series.