DEV Community

loading...

PixAI DevLog: Day 4

Nabil Alamin
random dude that exists
・1 min read

I should be done by now...

Been an interesting few days developing this app, here some of the stuff that happened:

  1. Finished fully responsive design of this in 2days. 😎😎

  2. Made 5 successful API calls using axios(turns out I'm not as incompetent as I thoughtπŸ˜…).

  3. Almost went crazy trying to make the last api work from base64 encoding to making the post request....finally I got in contact with the developers and they are trying to get it up at the moment( problem was from their side apparently).

That's basically it but I'm happy it turned out great.

I should be deploying by now, in fact I did but I took down cos my api_keys weren't secured, I've gone through posts about hiding stuff like on github with gitignore but I can't seem to get it working in production, all assistance is greatly appreciated

Alt Text

Later ✌

Discussion (6)

Collapse
ayanb profile image
Ayan Banerjee

I should be deploying by now, in fact I did but I took down cos my api_keys weren't secured, I've gone through posts about hiding stuff like on github with gitignore but I can't seem to get it working in production

You can add those to environmental variables. In fact, I am using those only to hide API keys: dev.to/ayanb/medidoc-update-4-depl... πŸ˜…

Collapse
arndom profile image
Nabil Alamin Author

Thanks for this, it worked.
The problem now is it has to be refreshed after each api call πŸ˜₯, any suggestions?

Collapse
ayanb profile image
Ayan Banerjee • Edited

Does your API key change after each call?

It's true that once you modify the environment variables the app has to be redeployed.

Thread Thread
arndom profile image
Nabil Alamin Author

No the key doesn't change that's why I'm confused, its until the page is refreshed then it works

Thread Thread
ayanb profile image
Ayan Banerjee

Then you have to change something in code I believe.

Does the same thing happen locally? Also, any error messages in browser console?

Thread Thread
arndom profile image
Nabil Alamin Author

Yh I figured it out, Omitted a dependency in useEfffect hook πŸ€§πŸ˜…. It's working smoothly now. Thanks