DEV Community

loading...
Cover image for Help! Error with Netlify build and Mapnik via react-mapbox-gl

Help! Error with Netlify build and Mapnik via react-mapbox-gl

Michael Schmerbeck
A motivated Fullstack JavaScript Engineer with a very emotional bond with React/Redux.
・14 min read

I upgraded locally to Catalina OS running v10.15.0 from existing project. Had so many node/zshell issues and just in general but got them fixed and this does build locally, usually it just needs an npm rebuild to fix a lot of these node related issues, but I am at a loss for this one.

It is coming from inside of Mapbox package. This is the same branch, develop, on Netlify that I am trying to build and I did one build with an npm-rebuild in case there was an issue with node versions somehow. Still the build command fails on develop branch on Netlify with output below:

also, running all packs I believe related to mapbox:
"@beyondtracks/spritezero-cli": "^2.3.0",
"react-mapbox-gl": "^4.6.0",
"mapbox-gl": "^1.3.1",

Thanks in advance for even looking at this nonsense!


4:14:23 PM: Build ready to start
4:14:25 PM: build-image version: 30f629161c0736b1a3ecd8b418e5eeffab5c0faf
4:14:25 PM: build-image tag: v3.3.14
4:14:25 PM: buildbot version: 26fde777289d855a94630a11cd6f77ce7c515bf8
4:14:25 PM: Fetching cached dependencies
4:14:25 PM: Failed to fetch cache, continuing with build
4:14:25 PM: Starting to prepare the repo for build
4:14:26 PM: No cached dependencies found. Cloning fresh repo
4:14:26 PM: git clone https://github.com/The-Smithy/ripspot-gatsby
4:14:27 PM: Preparing Git Reference pull/66/head
4:14:28 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: 'public' versus 'public/' in the Netlify UI
4:14:28 PM: Starting build script
4:14:28 PM: Installing dependencies
4:14:29 PM: Attempting node version 'v10.19.0' from .nvmrc
4:14:30 PM: Downloading and installing node v10.19.0...
4:14:30 PM: Downloading https://nodejs.org/dist/v10.19.0/node-v10.19.0-linux-x64.tar.xz...
4:14:31 PM: Computing checksum with sha256sum
4:14:31 PM: Checksums matched!
4:14:33 PM: Now using node v10.19.0 (npm v6.13.4)
4:14:33 PM: Started restoring cached build plugins
4:14:33 PM: Finished restoring cached build plugins
4:14:33 PM: Attempting ruby version 2.6.2, read from environment
4:14:35 PM: Using ruby version 2.6.2
4:14:35 PM: Using PHP version 5.6
4:14:35 PM: 5.2 is already installed.
4:14:35 PM: Using Swift version 5.2
4:14:35 PM: Started restoring cached node modules
4:14:35 PM: Finished restoring cached node modules
4:14:35 PM: Installing NPM modules using NPM version 6.13.4
4:14:38 PM: npm WARN
4:14:38 PM: deprecated loadable-components@2.2.3: Please use @loadable/component
4:14:41 PM: npm WARN deprecated core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
4:14:42 PM: npm WARN deprecated buffer@4.9.1: This version of 'buffer' is out-of-date. You must update to v4.9.2 or newer
4:14:42 PM: npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
4:14:43 PM: npm WARN deprecated intl-relativeformat@2.2.0: This package has been deprecated, please see migration guide at 'https://github.com/formatjs/formatjs/tree/master/packages/intl-relativeformat#migration-guide'
4:14:49 PM: npm WARN deprecated joi@11.4.0: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
4:14:50 PM: npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
4:14:51 PM: npm WARN deprecated popper.js@1.16.1: You can find the new Popper v2 at @popperjs/core, this package is dedicated to the legacy v1
4:14:58 PM: npm
4:14:58 PM:  WARN
4:14:58 PM: deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
4:15:00 PM: npm WARN deprecated hoek@4.2.1: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
4:15:00 PM: npm WARN deprecated topo@2.0.2: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
4:15:01 PM: npm WARN
4:15:01 PM: deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
4:15:03 PM: npm WARN deprecated protozero@1.5.1: protozero should no longer be used via npm, install instead via https://github.com/mapbox/mason
4:15:03 PM: npm WARN deprecated graphql-import@0.7.1: GraphQL Import has been deprecated and merged into GraphQL Tools, so it will no longer get updates. Use GraphQL Tools instead to stay up-to-date! Check out https://www.graphql-tools.com/docs/migration-from-import for migration and https://the-guild.dev/blog/graphql-tools-v6 for new changes.
4:15:04 PM: npm WARN deprecated
4:15:04 PM:  core-js@1.2.7: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
4:15:05 PM: npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
4:15:06 PM: npm WARN deprecated request@2.81.0: request has been deprecated, see https://github.com/request/request/issues/3142
4:15:06 PM: npm WARN deprecated hawk@3.1.3: This module moved to @hapi/hawk. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
4:15:08 PM: npm WARN deprecated hoek@2.16.3: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
4:15:08 PM: npm WARN deprecated cryptiles@2.0.5: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
4:15:08 PM: npm WARN deprecated sntp@1.0.9: This module moved to @hapi/sntp. Please make sure to switch over as this distribution is no longer supported and may contain bugs and critical security issues.
4:15:08 PM: npm WARN deprecated
4:15:08 PM:  boom@2.10.1: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
4:15:17 PM: npm WARN deprecated mkdirp@0.5.1: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)
4:16:11 PM: > mapnik@3.6.2 install /opt/build/repo/node_modules/mapnik
4:16:11 PM: > node-pre-gyp install --fallback-to-build
4:16:12 PM: node-pre-gyp
4:16:12 PM:  ERR! Tried to download(403): https://mapbox-node-binary.s3.amazonaws.com/mapnik/v3.6.2/node-v64-linux-x64-Release.tar.gz
4:16:12 PM: node-pre-gyp ERR! Pre-built binaries not found for mapnik@3.6.2 and node@10.19.0 (node-v64 ABI) (falling back to source compile with node-gyp)
4:16:12 PM: node-pre-gyp
4:16:12 PM:  ERR! Tried to download(undefined): https://mapbox-node-binary.s3.amazonaws.com/mapnik/v3.6.2/node-v64-linux-x64-Release.tar.gz
4:16:12 PM: node-pre-gyp
4:16:12 PM: ERR!
4:16:12 PM: Pre-built binaries not found for mapnik@3.6.2 and node@10.19.0 (node-v64 ABI) (falling back to source compile with node-gyp)
4:16:13 PM: /bin/sh: 1: mapnik-config: not found
4:16:13 PM: gyp: Call to 'mapnik-config --cflags' returned exit status 127 while in binding.gyp. while trying to load binding.gyp
4:16:13 PM: gyp
4:16:13 PM:  ERR! configure error
4:16:13 PM: gyp
4:16:13 PM: ERR! stack Error: `gyp` failed with exit code: 1
4:16:13 PM: gyp
4:16:13 PM:  ERR! stack     at ChildProcess.onCpExit (/opt/buildhome/.nvm/versions/node/v10.19.0/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:351:16)
4:16:13 PM: gyp
4:16:13 PM:  ERR! stack     at ChildProcess.emit (events.js:198:13)
4:16:13 PM: gyp
4:16:13 PM: ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)
4:16:13 PM: gyp ERR!
4:16:13 PM:  System Linux 4.14.138+
4:16:13 PM: gyp
4:16:13 PM: ERR! command
4:16:13 PM:  "/opt/buildhome/.nvm/versions/node/v10.19.0/bin/node" "/opt/buildhome/.nvm/versions/node/v10.19.0/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "configure" "--fallback-to-build" "--module=/opt/build/repo/node_modules/mapnik/lib/binding/mapnik.node" "--module_name=mapnik" "--module_path=/opt/build/repo/node_modules/mapnik/lib/binding"
4:16:13 PM: gyp
4:16:13 PM:  ERR!
4:16:13 PM:  cwd
4:16:13 PM:  /opt/build/repo/node_modules/mapnik
4:16:13 PM: gyp ERR!
4:16:13 PM:  node -v
4:16:13 PM:  v10.19.0
4:16:13 PM: gyp
4:16:13 PM:  ERR!
4:16:13 PM: node-gyp -v v5.0.5
4:16:13 PM: gyp
4:16:13 PM: ERR! not ok
4:16:13 PM: /bin/sh: 1: mapnik-config: not found
4:16:13 PM: gyp: Call to 'mapnik-config --cflags' returned exit status 127 while in binding.gyp. while trying to load binding.gyp
4:16:13 PM: node-pre-gyp ERR!
4:16:13 PM:  build error
4:16:13 PM: node-pre-gyp
4:16:13 PM:  ERR! stack Error: Failed to execute '/opt/buildhome/.nvm/versions/node/v10.19.0/bin/node /opt/buildhome/.nvm/versions/node/v10.19.0/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js configure --fallback-to-build --module=/opt/build/repo/node_modules/mapnik/lib/binding/mapnik.node --module_name=mapnik --module_path=/opt/build/repo/node_modules/mapnik/lib/binding' (1)
4:16:13 PM: node-pre-gyp
4:16:13 PM: ERR! stack     at ChildProcess.<anonymous> (/opt/build/repo/node_modules/mapnik/node_modules/node-pre-gyp/lib/util/compile.js:83:29)
4:16:13 PM: node-pre-gyp ERR! stack     at ChildProcess.emit (events.js:198:13)
4:16:13 PM: node-pre-gyp ERR! stack
4:16:13 PM:      at maybeClose (internal/child_process.js:982:16)
4:16:13 PM: node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:259:5)
4:16:13 PM: node-pre-gyp ERR! System Linux 4.14.138+
4:16:13 PM: node-pre-gyp ERR!
4:16:13 PM: command "/opt/buildhome/.nvm/versions/node/v10.19.0/bin/node" "/opt/build/repo/node_modules/mapnik/node_modules/.bin/node-pre-gyp" "install" "--fallback-to-build"
4:16:13 PM: node-pre-gyp ERR! cwd /opt/build/repo/node_modules/mapnik
4:16:13 PM: node-pre-gyp
4:16:13 PM:  ERR! node -v v10.19.0
4:16:13 PM: node-pre-gyp
4:16:13 PM:  ERR! node-pre-gyp -v v0.6.36
4:16:13 PM: node-pre-gyp
4:16:13 PM: ERR! not ok
4:16:13 PM: Failed to execute '/opt/buildhome/.nvm/versions/node/v10.19.0/bin/node /opt/buildhome/.nvm/versions/node/v10.19.0/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js configure --fallback-to-build --module=/opt/build/repo/node_modules/mapnik/lib/binding/mapnik.node --module_name=mapnik --module_path=/opt/build/repo/node_modules/mapnik/lib/binding' (1)
4:16:13 PM: gyp
4:16:13 PM: ERR!
4:16:13 PM: configure error
4:16:13 PM: gyp ERR! stack Error: `gyp` failed with exit code: 1
4:16:13 PM: gyp ERR! stack     at ChildProcess.onCpExit (/opt/buildhome/.nvm/versions/node/v10.19.0/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:351:16)
4:16:13 PM: gyp ERR!
4:16:13 PM:  stack     at ChildProcess.emit (events.js:198:13)
4:16:13 PM: gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:248:12)
4:16:13 PM: gyp
4:16:13 PM: ERR! System Linux 4.14.138+
4:16:13 PM: gyp ERR! command "/opt/buildhome/.nvm/versions/node/v10.19.0/bin/node" "/opt/buildhome/.nvm/versions/node/v10.19.0/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "configure" "--fallback-to-build" "--module=/opt/build/repo/node_modules/mapnik/lib/binding/mapnik.node" "--module_name=mapnik" "--module_path=/opt/build/repo/node_modules/mapnik/lib/binding"
4:16:13 PM: gyp ERR! cwd /opt/build/repo/node_modules/mapnik
4:16:13 PM: gyp
4:16:13 PM: ERR!
4:16:13 PM: node -v v10.19.0
4:16:13 PM: gyp ERR!
4:16:13 PM: node-gyp -v v5.0.5
4:16:13 PM: gyp ERR! not ok
4:16:16 PM: npm
4:16:16 PM:  WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.2.7 (node_modules/babel-plugin-add-module-exports/node_modules/chokidar/node_modules/fsevents):
4:16:16 PM: npm
4:16:16 PM:  WARN notsup
4:16:16 PM:  SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
4:16:16 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@~2.1.2 (node_modules/chokidar/node_modules/fsevents):
4:16:16 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
4:16:16 PM: npm WARN notsup Unsupported engine for watchpack-chokidar2@2.0.0: wanted: {"node":"<8.10.0"} (current: {"node":"10.19.0","npm":"6.13.4"})
4:16:16 PM: npm WARN notsup Not compatible with your version of node/npm: watchpack-chokidar2@2.0.0
4:16:16 PM: npm WARN draft-js-color-picker-plugin@1.2.0 requires a peer of draft-js@0.10.1 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-color-picker-plugin@1.2.0 requires a peer of react@15.5.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-color-picker-plugin@1.2.0 requires a peer of react-dom@15.5.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-embed-plugin@1.2.0 requires a peer of draft-js@0.10.1 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-embed-plugin@1.2.0 requires a peer of react@15.5.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-embed-plugin@1.2.0 requires a peer of react-dom@15.5.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-link-plugin@1.2.2 requires a peer of draft-js@0.10.1 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-link-plugin@1.2.2 requires a peer of react@15.5.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-link-plugin@1.2.2 requires a peer of react-dom@15.5.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-plugins-editor@2.1.1 requires a peer of draft-js@^0.10.1 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN gatsby-plugin-ts-loader@0.1.0 requires a peer of gatsby@~2.0.79 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN last-draft-js-sidebar-plugin@1.2.0 requires a peer of draft-js@0.10.1 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN last-draft-js-sidebar-plugin@1.2.0 requires a peer of react@15.5.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN last-draft-js-sidebar-plugin@1.2.0 requires a peer of react-dom@15.5.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN slick-carousel@1.8.1 requires a peer of jquery@>=1.8.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN find-with-regex@1.1.3 requires a peer of draft-js@^0.10.5 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN @pmmmwh/react-refresh-webpack-plugin@0.3.3 requires a peer of react-refresh@^0.8.2 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN eslint-config-react-app@5.2.1 requires a peer of eslint@6.x but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN acorn-dynamic-import@4.0.0 requires a peer of acorn@^6.0.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-buttons-plugin@1.2.0 requires a peer of draft-js@0.10.1 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-buttons-plugin@1.2.0 requires a peer of react@15.5.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-buttons-plugin@1.2.0 requires a peer of react-dom@15.5.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-modal-plugin@1.2.0 requires a peer of draft-js@0.10.1 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-modal-plugin@1.2.0 requires a peer of react@15.5.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-modal-plugin@1.2.0 requires a peer of react-dom@15.5.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN
4:16:16 PM:  draft-js-emoji-picker-plugin@1.2.0 requires a peer of draft-js@0.10.1 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-emoji-picker-plugin@1.2.0 requires a peer of react@15.5.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-emoji-picker-plugin@1.2.0 requires a peer of react-dom@15.5.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-gif-picker-plugin@1.2.0 requires a peer of draft-js@0.10.1 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-gif-picker-plugin@1.2.0 requires a peer of react@15.5.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: npm WARN draft-js-gif-picker-plugin@1.2.0 requires a peer of react-dom@15.5.0 but none is installed. You must install peer dependencies yourself.
4:16:16 PM: Failed during stage 'building site': Build script returned non-zero exit code: 1
4:16:16 PM: npm ERR! code
4:16:16 PM:  ELIFECYCLE
4:16:16 PM: npm ERR! errno 1
4:16:16 PM: npm ERR!
4:16:16 PM:  mapnik@3.6.2 install: `node-pre-gyp install --fallback-to-build`
4:16:16 PM: npm ERR! Exit status 1
4:16:16 PM: npm ERR!
4:16:16 PM: npm ERR!
4:16:16 PM:  Failed at the mapnik@3.6.2 install script.
4:16:16 PM: npm
4:16:16 PM: ERR! This is probably not a problem with npm. There is likely additional logging output above.
4:16:16 PM: npm
4:16:16 PM:  ERR! A complete log of this run can be found in:
4:16:16 PM: npm ERR!     /opt/buildhome/.npm/_logs/2020-05-29T20_16_16_077Z-debug.log
4:16:16 PM: Error during NPM install
4:16:16 PM: Error running command: Build script returned non-zero exit code: 1
4:16:16 PM: Failing build: Failed to build site
4:16:16 PM: Finished processing build request in 1m51.181977202s

Discussion (0)