DEV Community πŸ‘©β€πŸ’»πŸ‘¨β€πŸ’»

Cover image for M-One Personal Assistant v2.4 - Update: Friday, June 24, 2022 + GUI v1.0
Mahdi
Mahdi

Posted on

M-One Personal Assistant v2.4 - Update: Friday, June 24, 2022 + GUI v1.0

Hello friends,

Update 2.4 of M-One Assistant has been released.

Version 2.4 (Update: Friday, June 24, 2022):

M-One in version 2.4 can do 81 things.

Important changes in version 2.4:

change voice, in what language are you written, do you know me, set alarm (Download Music for Alarm), edit note, open calculator, open disk c & d & e, open task manager, toggle capslock, toggle numlock, start menu, and fix program bugs...

And a graphic version of M-One has been released.

M-One (v2.0) GUI v1.0:

Includes interface Typing and Listening - GUI_v1.0

Screenshots

Image description

Image description

Image description

Core Dependencies

Python 3 (3.9.7)
SpeechRecognition
subprocess (version 2.0)
webbrowser
threading (version 2.4)
winsound (version 2.4)
tkinter (version 2.0 - GUI v1.0)
wikipedia
pyautogui (version 2.0)
translate
requests
pyqrcode
platform (version 2.0)
winshell (version 2.0)
datetime
PyAudio
pyttsx3
random (version 2.0)
urllib
whois (version 2.0)
time
os

Project at GitHub: https://github.com/Mhadi-1382/M-One-personal-assistant

Learn more about M-One: https://dev.to/mhadi2003/m-one-personal-assistant-v10-l0h

In the future, some features of this program will be added and some of its shortcomings will be eliminated.
You dear ones can also express your opinions and suggestions.

Top comments (6)

Collapse
 
moesalim88 profile image
Moe Salim

Interesting project mate. However I have not been able to try it as the pip installations seem to fail:

PS C:\Users\Mojojo\Desktop\Developer\M-ONE Personal Assistant> .\setup.bat
Installing Packages
Requirement already satisfied: SpeechRecognition in c:\python310\lib\site-packages (from -r packages.txt (line 1)) (3.8.1)
ERROR: Could not find a version that satisfies the requirement subprocess (from versions: none)
ERROR: No matching distribution found for subprocess
Installing Completed.
Press any key to continue . . .

Collapse
 
mhadi2003 profile image
Mahdi Author

Hi, thank you very much for your comment. You can install the desired package with the pip install command:
pip install SpeechRecognition

And regarding the subprocess package, this package is installed by default in the Python library and does not need to be installed.

And make sure that the Python version must be 3.9.7.

And finally, run the Python file and suggest that you do this in Vscode.

Collapse
 
moesalim88 profile image
Moe Salim

I see. I did try to install the pip packages individually, it didn't work. My setup is python 3.10, that could be why. Planning on making your code 3.10 compatible?

Thread Thread
 
mhadi2003 profile image
Mahdi Author

Unfortunately, it is not possible to change the version at the moment, maybe this will happen in the coming months.

Thread Thread
 
moesalim88 profile image
Moe Salim

Looking forward to trying it when it's ready. Good luck :)

Thread Thread
 
mhadi2003 profile image
Mahdi Author

Thank you πŸ™

🌚 Life is too short to browse without dark mode