DEV Community

Discussion on: How To For Loop Through Anything in JS

leob profile image

Why is it more semantical to write "arr.forEach(...)" instead of "for (... of arr)" ? Seems merely a matter of syntax and taste to me ...

Thread Thread
jacobmparis profile image
Jacob Paris Author

I would absolutely consider this to be a matter of taste

Thread Thread
patarapolw profile image
Pacharapol Withayasakpunt

I meant arr.forEach() vs

for of and for in are another species, and is whether you want it to be functional or procedural. Neither is better than the others.