Discussion on: Getting started with Hyperledger Composer and private blockchains

haso71 profile image

Hallo Damien, hopefully you could help me! As a beginner I have some installation problems: I set up a brand new Ubuntu 16.04 and got far (with so deprecation warnings) throw your guide until:
1.) Starting ./createPeerAdminCard.sh: brings some kind of warning: "Need to have composer-cli installed at v0.19 or greater"

2.) "composer archive create -t dir -n ." brings an error:
module.js:549 throw err; Error: Cannot find module './api' ...

I didn´t find any api-files, so whats wrong?

damcosset profile image
Damien Cosset Author

Hey there.

For the first problem, you most likely need to update your composer-cli package version to 0.19. Or install it if you haven't: npm install -g composer-cli or npm update -g composer-cli should get the job done.

I'm not sure about the second one though. Try again with the updated version of composer. If you still have an error, could you show the entire error message?

Note: I updated the article for the new composer network install command.

Good luck!

haso71 profile image

thank you for the fast answer, so I tried to check all versions on my system, for my opinion, i already had composer-cli installed at v0.19.0 before.

// -- version check ----
haso71@ubuntu:~/hyperledger/fabric-tools$ docker-compose --version
docker-compose version 1.20.1, build 5d8c71b
haso71@ubuntu:~/hyperledger/fabric-tools$ yo --version
haso71@ubuntu:~/hyperledger/fabric-tools$ nodejs -v
haso71@ubuntu:~/hyperledger/fabric-tools$ node -v
haso71@ubuntu:~/hyperledger/fabric-tools$ npm -v
haso71@ubuntu:~/hyperledger/fabric-tools$ go version
go version go1.6.2 linux/amd64

haso71@ubuntu:~/hyperledger/fabric-tools$ sudo npm install -g composer-cli
npm WARN deprecated fs-promise@1.0.0: Use mz or fs-extra3.0 with Promise Support
/usr/bin/composer -> /usr/lib/node_modules/composer-cli/cli.js
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules/composer-cli/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

haso71@ubuntu:~/hyperledger/fabric-tools$ sudo ./createPeerAdminCard.sh
Development only script for Hyperledger Fabric control
Running 'createPeerAdminCard.sh'
FABRIC_VERSION is unset, assuming hlfv11
FABRIC_START_TIMEOUT is unset, assuming 15 (seconds)

Need to have composer-cli installed at v0.19 or greater

haso71@ubuntu:~/hyperledger/fabric-tools/land-registry$ composer archive create -t dir -n .
throw err;
Error: Cannot find module './api'
at Function.Module._resolveFilename (module.js:547:15)
at Function.Module._load (module.js:474:25)
at Module.require (module.js:596:17)
at require (internal/module.js:11:18)
at Object. (/usr/lib/node_modules/composer-cli/node_modules/node-report/index.js:3:13)
at Module._compile (module.js:652:30)
at Object.Module._extensions..js (module.js:663:10)
at Module.load (module.js:565:32)
at tryModuleLoad (module.js:505:12)
at Function.Module._load (module.js:497:3)
haso71@ubuntu:~/hyperledger/fabric-tools/land-registry$ ls -l
total 32
drwxrwxr-x 3 admin admin 4096 Apr 2 01:34 features
drwxrwxr-x 2 admin admin 4096 Apr 2 01:46 lib
drwxrwxr-x 2 admin admin 4096 Apr 2 01:43 models
-rw-r--r-- 1 admin admin 878 Apr 2 01:34 package.json
-rw-r--r-- 1 admin admin 356 Apr 2 01:49 permissions.acl
-rw-rw-r-- 1 admin admin 1588 Apr 2 01:49 permissions(original).acl
-rw-r--r-- 1 admin admin 57 Apr 2 01:34 README.md
drwxrwxr-x 2 admin admin 4096 Apr 2 01:34 test