DEV Community

Muhammad Iqbal
Muhammad Iqbal

Posted on

Cara Beralih atau Berpindah di antara beberapa versi PHP di Ubuntu/Linux

Pada pembahasan kali ini, saya akan mencoba untuk memandu anda melalui langkah-langkah bagaimana cara beralih di antara berbagai versi PHP yang sudah terpasang pada sistem Ubuntu/Linux ataupun turunannya. Pada panduan ini secara resmi pada versi Ubuntu 20.04 LTS. Akan tetapi dapat dimungkinkan bekerja pada versi Ubuntu yang lebih lama atau yang lebih baru.

Pengantar

Terkadang, versi terbaru dari paket atau aplikasi yang anda pasang (install) mungkin tidak berfungsi sesuai dengan yang anda harapkan. Aplikasi anda mungkin tidak kompatibel dengan paket yang diperbarui dan hanya mendukung paket versi yang lebih lama tertentu.
Dari kejadian tersebut, anda tidak perlu menurunkan ataupun menghapus (uninstall) versi PHP yang sebelumnya apabila disuatu hari anda masih membutuhkannya. Anda cukup beralih ke versi PHP yang aplikasi perlukan hanya dalam beberapa menit saja.

Prasyarat

  1. Sebuah sistem Ubuntu/Linux yang sudah berjalan atau sistem turunannya.
  2. Pada tahapan kali ini saya tidak akan menjelaskan tentang bagaimana cara memasang PHP. Pastikan anda telah memasang beberapa versi PHP di sistem anda.

Mari Kita Mulai

  1. Periksa versi bawaan PHP yang sudah terpasang pada sistem anda dengan menggunakan perintah seperti berikut:
php -v
Enter fullscreen mode Exit fullscreen mode

Maka akan tampil keluaran seperti berikut:

PHP 7.3.33-1+ubuntu20.04.1+deb.sury.org+1 (cli) (built: Nov 19 2021 06:25:05) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.33, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.33-1+ubuntu20.04.1+deb.sury.org+1, Copyright (c) 1999-2018, by Zend Technologies
Enter fullscreen mode Exit fullscreen mode

Seperti yang anda lihat, PHP yang terinstal yaitu versi 7.3
*Terdapat versi PHP 7.3 pada sistem saya, ini bisa berbeda di sistem anda. Jadi jangan khawatir. ;)

Aplikasi anda mungkin memerlukan versi yang lebih tinggi dari yang sekarang (dalam hal ini aplikasi saya membutuhkan dukungan PHP 7.4) dan aplikasi saya tidak mendukung versi PHP 7.3. Dalam hal ini, saya menyarankan memiliki PHP versi 7.3 dan versi PHP 7.4, sehingga anda dapat dengan mudah beralih di antara versi yang didukung kapan saja.

  1. Anda dapat menjalankan perintah berikut dibawah untuk mengatur versi PHP yang sudah terinstal pada sistem anda dan ingin anda gunakan secara bawaan. (Dalam hal ini saya memilih 0 untuk versi PHP 7.4). Ketikkan 0 lalu enter maka versi PHP akan berubah.
sudo update-alternatives --config php
Enter fullscreen mode Exit fullscreen mode

Maka akan tampil keluaran seperti berikut:

There are 2 choices for the alternative php (providing /usr/bin/php).

     Selection    Path             Priority   Status
    ------------------------------------------------------------
      0            /usr/bin/php7.4   74        auto mode
    * 1            /usr/bin/php7.3   73        manual mode
      2            /usr/bin/php7.4   74        manual mode

Press <enter> to keep the current choice[*], or type selection number: 0
update-alternatives: using /usr/bin/php7.4 to provide /usr/bin/php (php) in auto mode
Enter fullscreen mode Exit fullscreen mode
  1. Sekarang, coba cek lagi dengan perintah seperti berikut apakah versi PHP bawaan sudah berubah atau tidak.
php -v
Enter fullscreen mode Exit fullscreen mode

Maka akan tampil keluaran seperti berikut:

PHP 7.4.27 (cli) (built: Dec 20 2021 21:28:15) ( NTS )
Copyright (c) The PHP Group Zend Engine v3.4.0, Copyright (c) Zend Technologies
    with Zend OPcache v7.4.27, Copyright (c), by Zend Technologies
Enter fullscreen mode Exit fullscreen mode

Baik, versi PHP sudah berubah dan kita sudah berhasil beralih versi PHP dengan mudah. Semoga membantu dan terima kasih. Semoga berhasil :)

Discussion (0)