loading...

ERROR: Failed to build gem native extension.

ameedjamous profile image Ameed Jamous ・2 min read

Are you unable to install cocoapods on maxOS Catalina ? here is what might work for you.

On macOS Catalina I faced several issues install cocoapods, and below is the solution.

sudo gem install -n /usr/local/bin cocoapods
Building native extensions. This could take a while...
ERROR:  Error installing cocoapods:
    ERROR: Failed to build gem native extension.

    current directory: /Library/Ruby/Gems/2.6.0/gems/ffi-1.12.2/ext/ffi_c
/System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/bin/ruby -I /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0 -r ./siteconf20200416-2584-hct4l8.rb extconf.rb
mkmf.rb can't find header files for ruby at /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /Library/Ruby/Gems/2.6.0/gems/ffi-1.12.2 for inspection.
Results logged to /Library/Ruby/Gems/2.6.0/extensions/universal-darwin-19/2.6.0/ffi-1.12.2/gem_make.out
ameedjamous@Ameeds-iMac O2IOS-master % sudo gem install -n /usr/local/bin ruby-dev
ERROR:  Could not find a valid gem 'ruby-dev' (>= 0) in any repository
ERROR:  Possible alternatives: ruby_dev
ameedjamous@Ameeds-iMac O2IOS-master % sudo gem install -n /usr/local/bin ruby-devel
ERROR:  Could not find a valid gem 'ruby-devel' (>= 0) in any repository
ERROR:  Possible alternatives: ruby_dev, rubdev, ruby-DTL, ruby-avl, ruby-d2l

Solution getting cocopods workings on macOS Catalina


# brew cleanup -d -v    
# brew install cocoapods

Thought others might find this useful.

Posted on by:

ameedjamous profile

Ameed Jamous

@ameedjamous

Founder @TelecomsXChange (TCXC) | Tech Evangelist @Telestax

Discussion

markdown guide
 
 

Glad you find it useful! cheers.

 

Thanks a lot, i faced the exact issue