Yes, the naming isn't optimal, I think.
useState is pretty straight-forward, but useEffect not so much.
On the other hand, they are basic building blocks used to create more sophisticated hooks that would have clearer names.
useFetch, useHttp, useTrackingApi, useFacebookLogin etc.
We're a place where coders share, stay up-to-date and grow their careers.
We strive for transparency and don't collect excess data.