DEV Community

Discussion on: Why Running `yarn upgrade` Does Not Update My `package.json`

Collapse
jianwu profile image
jianwu

It's just a weird design of yarn upgrade. Anyway thanks for your article which saved my day.

I faced a bug because of the old dependencies. Tried yarn upgrade, never get it to work.

I finally upgraded all my versions in my package.json and solved my problem by removing the version range. And run:

yarn upgrade --latest