loading...

New React Hook: πŸ“¦ use-is-mounted-ref

helderburato profile image Helder Burato Berto ・1 min read

Today I moved a hook that I use to fix the problem of setting the state to an unmounted component and commonly receives the following error:

Warning: Can only update a mounted or mounting component. This usually means you called setState, replaceState, or forceUpdate on an unmounted component. This is a no-op.

I created the following package:
use-is-mounted-ref

Maybe this can help you to solve this same problem. :)

Feel free to give feedback and share your experience with this topic.

Discussion

markdown guide