DEV Community

loading...

Gatsby build cron issue..!!

Gurupal Singh
・1 min read

Hi, I am trying to Build static pages for gatsby from a bash script. Bash script is working fine but whenever i try to run it via crontab it throw error for node and npm.

Node version i am using is v10.13.0 and npm version is v6.4.1.

But somehow cron log gives me error which shows my node version v8.10.0 and npm version v3.5.2. Screenshot attached for the same.

Even i do not have node v8 installed on my server. Both on root and ubuntu user.

Why it is taking node version 8 for cronjob?

Discussion (0)