Depends what the codes for really.
Math.max() is easier to read, and if only run occasionally on small arrays... fine.
Reduce is a little more convoluted, but still can be understood easily enough. The time savings on the code if running frequently or on larger datasets can quickly add up in benefits.
We're a place where coders share, stay up-to-date and grow their careers.
We strive for transparency and don't collect excess data.