DEV Community

Kokomi
Kokomi

Posted on • Updated on

Replace Generic Validation with Reusable Functions

JavaScript and TypeScript developers often find themselves writing the same conditions repeatedly. If you're a web developer, you've probably encountered code like this:

const handleSaveTextKeydown = (event: KeyboardEvent) => {
   if (event.key === 'Enter') {
    //... save text
   }
}
Enter fullscreen mode Exit fullscreen mode

In this case, event.key is of type string, and it's easy to introduce bugs by accidentally including a space in 'Enter ', for example.

Why not encapsulate this condition in a function?

const handleSaveTextKeydown = (event: KeyboardEvent) => {
   if (checkIsEnterKey(event.key)) {
    //... save text
   }
}
Enter fullscreen mode Exit fullscreen mode

This ensures that all checks for the Enter key are consistent and reliable.

Now, consider this validation:

type Value = null | object;

const value = {} as Value;

if (typeof value === 'object') {
  value; // value type is null | object
}
Enter fullscreen mode Exit fullscreen mode

Even though TypeScript is smart, value inside the condition remains of type Value. This is because typeof null returns 'object'.

So, you need to write:

if (value !== null && typeof value === 'object') {
  value; // value type is object
}
Enter fullscreen mode Exit fullscreen mode

Many developers might not encapsulate this into a function and instead write it repeatedly whenever they encounter this situation.

How many times have you written the same condition in your life?

How many times have you made the same mistake?

How many more times will you write the same condition in the future?

If it were me, I would do this:

if (checkIsObject(value)) {
  value; // value type is object
}
Enter fullscreen mode Exit fullscreen mode

There are many benefits to encapsulating generic conditions in functions.

Consider the following example:

const array = [0, 1, 2, 3, 4, 5, null, undefined];
Enter fullscreen mode Exit fullscreen mode

Let's create an array that excludes only nullish values.

You might prioritize brevity and write it like this:

const numbers = array.filter(Boolean);
Enter fullscreen mode Exit fullscreen mode

Unfortunately, this is not ideal. 0 is also evaluated as false and gets excluded. So you need to write:

const numbers = array.filter(item => item !== null && item !== undefined);
Enter fullscreen mode Exit fullscreen mode

Doesn't this feel like ugly, non-reusable code?

I can write more elegant code:

const numbers = array.filter(checkIsNullish);
Enter fullscreen mode Exit fullscreen mode

Stop writing generic conditions repeatedly. It only leads to mistakes, and the code becomes less readable.

Let me introduce a library I created called checker.

This utility function library represents commonly used conditions in general web development and low-level development as functions. All functions take an input and return a boolean value.

At the time of writing this article, it provides a wealth of functions to handle data types such as strings, numbers, booleans, and nullish values. All functions are tested, documented, and easy to start using.

Let's look at some real-world examples.

The packages provided by this library are all published on JSR. They can be easily installed in NPM, PNPM, Yarn, Bun, and Deno projects.

Here, we'll take the @checker/string package as an example with NPM.

  1. Install the package

Run the following command in your project directory:

  npx jsr add @checker/string
Enter fullscreen mode Exit fullscreen mode
  1. Using the functions
  import { checkIsNotEmptyString, checkIsIndexFound } from "@checker/string";

  const value = "Hello";

  const formatted = value.trim();

  if (checkIsNotEmptyString(formatted)) {
    // formatted !== ''
    // When formatted is not an empty string
  }

  const index = value.indexOf("el");

  if (checkIsIndexFound(index)) {
    // index !== -1
    // When "el" is found in value
  }
Enter fullscreen mode Exit fullscreen mode

I am not fond of using logical negation operators like !SOME_CONDITION to reverse a boolean value. This is because it's implicit, and simply reversing the boolean value by adding or omitting it can lead to many dangerous situations.

Therefore, all functions have corresponding checkIsNot~ functions defined.

Encapsulate generic conditions in functions. This way, the code becomes more readable, and bugs become easier to spot.

Thank you for reading.

Top comments (0)