DEV Community

Calin Baenen
Calin Baenen

Posted on

Small ParseJS update; makes code inside of `parse_string` easier to read.

You can see the commit on GitHub here.
Today I made a small change to the code of parse_string to make it easier to follow along with.

Here's the change:
Image of the commit I made to GitHub.

Discussion (6)

Collapse
adam_cyclones profile image
Adam Crockett

Hey ๐Ÿ‘‹ so to my old eyes, I feel that things are easier to read when expanded into meaningful names rather than single letters. When you come back to this code you may think... What is this? And you would hope to actually go, I remember this!

Collapse
adam_cyclones profile image
Adam Crockett

I mean this sincerely, shorter code is not easier code. Code was invented to instruct machines in a human interactive interface, the code will not run any slower with slightly longer variable names. It may downloaded an absolutely miniscule amount slower but that is a price we should all be wiling to pay for maintainable code for yourself and potentially a team of others if this thing goes viral

Collapse
baenencalin profile image
Calin Baenen Author

if this thing goes viral

If this 'thing' goes viral?
Well, why don't you just spread the good word, and help it become viral? ๐Ÿคจ

Collapse
baenencalin profile image
Calin Baenen Author • Edited on
Collapse
adam_cyclones profile image
Adam Crockett

Looks great yep

Collapse
baenencalin profile image
Calin Baenen Author

Thanks for the feedback.
I'll give them slightly longer names.