DEV Community

Discussion on: Back to basics: Naming

Collapse
 
andreandyp profile image
André Michel Andy

Personally, I would use the third option because it looks great along with the if statement.

About the first, I think is not an appropriate name: the function's name says that the function will do some kind of modifications to the input email and then, return it.

About the second, I would use it if email were an object:

if(email.isValid()){
    //do some stuff
}
Collapse
 
lucasmonstro profile image
Lucas Silva

Only if you have an email object :-D

Collapse
 
sadick profile image
Sadick

Interesting. And what would be the structure of that email object.

Collapse
 
andreandyp profile image
André Michel Andy

I think it will be like this:

class Email {
  constructor(email){
    this.email = email;
  }
  get user(){
    //return text before '@'
  }
  get domain(){
    //return domain
  }
  get tld(){
    //return top-level-domain
  }
  isValid(){
    //validate email string given in constructor
  }

}

For a lexical analyzer or something like that

Thread Thread
 
lioobayoyo profile image
lioobayoyo

not meaning to troll or so, but you can have user@ipaddress as a validemail ;)