re: How did we make open source CI better? VIEW POST

TOP OF THREAD FULL DISCUSSION
re: Drone 1.0 is backward compatible with the 0.8 yaml configuration file. If you have an example of an 0.8 file that does not work with 1.0 you can po...
 

I'm read this:

There is no automated upgrade path from version 0.8.x to 1.0.0. There were incompatible changes to the database that will require an advanced migration utility.

and this

There were significant, breaking changes to the yaml configuration format in this release. Please note, however, 1.0.0 is capable of processing yaml files in the legacy 0.8.x yaml format (with the exception of matrices).

On your site docs.drone.io/releases/1.0.0-rc.1/...

And decided to stay on 0.8 for a while

that post was a few months old (from rc.1). As of rc.5 we added support for reading 0.8 matrix configurations and just last week we published an automated migration utility. github.com/drone/drone-migrate

Thank you! Where I can get the latest docs? Seems like rc1 is the freshest one on the official docs page.

code of conduct - report abuse