I like it and I generally agree. In the end readability is better this way. The function name is very useful to know what's actually happening at a glance, otherwise you would have to parse the entire code to realise what's going on.
We're a place where coders share, stay up-to-date and grow their careers.
We strive for transparency and don't collect excess data.