DEV Community πŸ‘©β€πŸ’»πŸ‘¨β€πŸ’»

DEV Community πŸ‘©β€πŸ’»πŸ‘¨β€πŸ’» is a community of 968,873 amazing developers

We're a place where coders share, stay up-to-date and grow their careers.

Create account Log in
Maya
Maya

Posted on

React js project shows vulnerabilities when executing "npm install"

I got a project from my client in which the backend is lumen and the front end is reactjs and I want to do the enhancements on that.

Lumen gets installed successfully. But I failed to install the reactjs project.

When I executed "npm install" inside the folder It shows 33 vulnerabilities. And when executing the npm audit I found that the issue is for the module "node-saas 5.0.0"

First I executed the project in node 16.15.0 and after that realized that node-saas 5.0.0 is compatible with node 15

So I switched to node 15.0.0. Again it shows other vulnerabilities for the modules like jest and more.

Every time I resolve the problem that getting from the npm audit, the new one arises. How can I solve this issue?

Top comments (1)

Collapse
 
_bkeren profile image
'' • Edited on

First, you want to say node-sass, I guess
Is node-sass@5.0.0 used directly in package.json or does it come indirectly?
Have you seen github.com/sass/node-sass/releases compatibility table?

🌚 Friends don't let friends browse without dark mode.

Sorry, it's true.