DEV Community

loading...

S’occuper d’une erreur FillDataElements en Jitterbit

katiekodes profile image Katie Originally published at katiekodes.com on ・2 min read

Aujourd’hui, c’est l’Halloween. Et Jitterbit m’a bien effrayé en lançant une erreur FillDataElements lorsque j’élaborais une opération d’insertion Salesforce.

Hou là là !

Heureusement, j’ai découvert une bêtise (réélaborer l’opération de zéro) qui m’a plu autant que des friandises.


Face à l’erreur:

FillDataElements() failed (bad data)

Qui continue peut-être :

This occurs when constructing source data element “…” for target node “root$transaction…

Il est possible que vous trouverez un de ces articles du site GetSatisfaction.com:

  1. FillDataElements() failed (bad data)
  2. Date Period Year out of Range - Format issue?

Ces deux articles m’ont aidé à voir qu’il y avait peut-être quelque chose dans la configuration de mon opération qui causait du chaos en Jitterbit:

  1. J’avais déclaré un champs d’un fichier CSV « TEST_DATE ») d’être une date et pas une chaîne de caractères (« string »).
  2. Dans le fichier CSV, il y a des enregistrements où TEST_DATE est vide.
  3. J’ai peut-être tapé une erreur en scriptant une condition sur TEST_DATE pour la « transformation ».

Après avoir tout corrigé, le bouton « test the transformation » lançait toujours l’erreur FillDataElements.

Enfin j’ai:

  1. réélaboré le « File Format » (avec tous les champs déclarés des chaîne de caractères)
  2. recommencé de zéro avec l’assistant “Salesforce Insert Operation”

Je ne sais pas lequel des deux a corrigé la situation, mais l’erreur a bien disparu.

Discussion (0)

pic
Editor guide