The currentSum is meant to be the accumulator, so I think the code block is correct it's just the language above it that's ambiguous. I had intended it to be something that meant closer to "notice how we have a new parameter" rather than implying the number was the accumulator. Either way, I'll go back and try and clear that language up. Thanks for pointing this out!
We're a place where coders share, stay up-to-date and grow their careers.
We strive for transparency and don't collect excess data.