loading...

Discussion on: You Should Upgrade to Angular 9 TODAY

Collapse
fergalmoran profile image
Fergal Moran

Don't do this if you have a reasonably complex project, it's nowhere near ready. Ivy breaks pretty much everything.

Collapse
frosty profile image
Aaron Frost Author

Fergal, Google has dozens of reasonably complex projects that are working fine. If you care to talk about what you ran in to, I can see if I can help (or get the Angular team to look at it with you).

Collapse
fergalmoran profile image
Fergal Moran

Sure - first off ng update failed with

[error] Error: Package install failed.
at installPackage (/home/fergalm/dev/myproj/myproj-web/node_modules/@angular/cli/tasks/install-package.js:36:15)
at installTempPackage (/home/fergalm/dev/myproj/myproj-web/node_modules/@angular/cli/tasks/install-package.js:73:5)
at Object.runTempPackageBin (/home/fergalm/dev/myproj/myproj-web/node_modules/@angular/cli/tasks/install-package.js:82:33)
at UpdateCommand.run (/home/fergalm/dev/myproj/myproj-web/node_modules/@angular/cli/commands/update-impl.js:37:38)
at async UpdateCommand.validateAndRun (/home/fergalm/dev/myproj/myproj-web/node_modules/@angular/cli/models/command.js:134:28)
at async Object.runCommand (/home/fergalm/dev/myproj/myproj-web/node_modules/@angular/cli/models/command-runner.js:186:24)
at async default_1 (/home/fergalm/dev/myproj/myproj-web/node_modules/@angular/cli/lib/cli/index.js:54:31)%  

So.. I updated the packages manually in package.json, then ran ng update --migrateOnly
Then the horrowshow began!!

'router-outlet' is not a known element

A large number of

 error TS-998004: No pipe found with name 'async'

Literally hundreds of errors of the type

'my-component' is not a known element

and

Can't bind to '<property>' since it isn't a known property of 'my-component'

I played wackamole with the errors for as long as I could but unfortunately I don't have a huge amount of time to devote to this just now so I had to revert back to 8.2

Thread Thread
frosty profile image
Aaron Frost Author

Wow. That sucks! I feel for you. That must have been frustrating.

If you went to look at it together, we can.

If I were to try it again, I would remove all node_modules, then reinstall, and THEN attempt to do the upgrade. Not sure it will help. I just like to eliminate possible corrupt modules from the equation.

Let me know if you want another set of eyes.

Thread Thread
fergalmoran profile image
Fergal Moran

Hi Aaron

Yeah - I already tried removing node_modules and retrying, still the same.
I'm gonna take a break from it for now but will definitely take you up on your kind offer next time I try!

Fergal.

Thread Thread
fergalmoran profile image
Fergal Moran

RC8 is orders of magnitude better, still lots of weird errors and template cleaning up required but a calm and level headed error by error approach worked wonders (it kind of reminded me of my STL programming days where fixing one issue resolved 100 compile errors 😱 ). Definitely a really nice "feel" to this release, all the template issues I had to fix were down to poor coding on my behalf, the time spent fixing them really feels like time well spent! And now I have a running, tests passing angular-9-rc8 version of my app!!

Thanks again for your support and for writing the article that pushed me to get it done!