DEV Community

Discussion on: One-liner to update npm dependency packages to the latest version using jq

Collapse
craftzdog profile image
Takuya Matsuyama Author

Because it does not always update packages to the latest versions if those are caret/tilde dependencies:

docs.npmjs.com/cli-commands/update...

It means that npm update tries to update while keep satisfying app's package dependencies.