loading...

Why you should give Array.prototype.reduce() a chance too?🧐

kapeel kokane on March 06, 2020

Let's Admit, There is that one array method (usually .map or .forEach) which is close to our heart ❤️ and that is the one which we try t... [Read Full]
markdown guide
 

I though this was on the topic of overusing reduce which was brought up by Jake Archibald recently on twitter.

They were arguing that beside summing, reduce should be avoided in favor of for loops as they were easier to read and faster.

Object.fromEntries can help remove a lot of reduces too when generating objects.

If you want a method to rule them all, reduce is your best bet, but don't.

Learn map and filter they have very clear and distinct roles, now days I favor for..of over forEach.

 

Yes correct. I brought this up to highlight the other sentiment which is: 'use map/forEach all the time', even in cases where reduce could have been your best bet.
This is another awesome video on the same topic:

 

Yes well, that's jake haha

code of conduct - report abuse