re: dev.to open source help/discussion thread (v0) VIEW POST

FULL DISCUSSION
 

Here's something I ran into as I'm going through the setup instructions, in case anyone else has the same problem.

When I did gem install bundler, I got this error message:

Fetching: bundler-1.16.5.gem (100%)
ERROR:  While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions for the /Library/Ruby/Gems/2.3.0 directory.

It might have occurred because I uninstalled rvm (using rvm implode ) after installing rbenv.

The fix (found here ) was to add eval "$(rbenv init -)" to my .bash_profile (then do source ~/.bash_profile). After that gem install bundler worked.

 
 
 

I can't explain how helpful this is. You saved me from a great amount of trouble. Thank you!

code of conduct - report abuse