DEV Community

Discussion on: Status instead of isLoading boolean?

c5n8 profile image

I made a package around this idea for Vue.
The challenge is to name the state when we have not called the function for the first time. I call it standby, but I think it could be better.
Also, if only Javascript/Typescript has implicit member expression like Swift, we could eliminate these space hogging strings, masquerading as a pseudo enum.