That's why it's important use well named variables, imagine that your first approach with reduce was this way:
arr.reduce((accumulator, currentValue) => accumulator + currentValue);
arr.reduce((accumulator, currentValue) => accumulator + currentValue)
Much better, don't you think so? It's almost self explanatory...
I'm pretty sure I would still have found a way to be confused by it, hahaha
But I do agree that clear naming goes a long way to help understand code.
We're a place where coders share, stay up-to-date and grow their careers.
We strive for transparency and don't collect excess data.