nil + compact also seems overkill :/ Feels like an extra operation when I can skip it with a single line if.
you're right, the first solution is the clearest
The alternatives are "tricks" :D
We're a place where coders share, stay up-to-date and grow their careers.
We strive for transparency and don't collect excess data.