DEV Community

Discussion on: Daily Challenge #82 - English Beggars

Collapse
 
aminnairi profile image
Amin

I'm not sure as I can't test it out here but I think that this line

const sums = [...Array(beggarsNumber)].map(_ => 0);

Could have been written as

const sums = [...Array(beggarsNumber)].fill(0);

Even if it is a small change, I find it easier to read.

Collapse
 
tomf_31 profile image
Tōm

Thank you for your response, it can also be changed as :

const sums = Array(10).fill(0);

I forgot this function, and it is really helpful and permits to avoid the hackish code I wrote above.

Thanks!